Health iPASS - TrustCommerce Payments – Incident details

Sphere experiencing partial outage

TrustCommerce Payments

Identified
Partial outage 50 %
Started 3 days ago

Affected

Payment Processing

Partial outage from 1:00 PM to 12:00 AM

Sphere

Partial outage from 1:00 PM to 12:00 AM

Updates
  • Update
    Update

    Dear TrustCommerce & Health iPASS Clients,


    We would like to inform you that payments from September 24 through October 7 have been successfully recovered. These transactions have been re-entered into Health iPASS and are now ready for posting, pending your review and approval.

    The corresponding lists of transactions will be shared within any open support tickets you currently have with us. If you were impacted but do not have an existing ticket, our team will create one on your behalf and provide the relevant details there. Please note that when posting these payments in Health iPASS, the payment date in your PM system will reflect the posting date.

    We sincerely apologize for the inconvenience this issue may have caused and greatly appreciate your patience and understanding as we work toward a permanent resolution. Our engineering teams are actively investigating and implementing measures to prevent recurrence. We will continue to keep you informed of any updates and will share another report once the matter is fully resolved.

    Thank you once again for your partnership and continued trust.

    Warm regards,

    Health iPASS Support Team

  • Identified
    Identified

    Hello TrustCommerce and Health iPASS Clients,

    We have identified some intermittent issues that we are working to correct: missing transactions from Health iPASS, spinning when patients are trying to make payments, and the option to pay with a PAX device even if there is not one present. We have deployed some code and are seeing improvements, but are continuing towards correcting any lingering symptoms as soon as possible and will keep you informed via any open tickets.

    If you are experiencing an issue that is not related to one of these, we ask that you open a ticket with us using the ticket portal or emailing us a help@healthipass.com.

    Thank you for your patience and continued partnership as we work through these issues,

    Health iPASS Support